Announcement

Collapse
No announcement yet.

I have a 2001 SL2 Original owner. 5-speed. 390,000 miles.... It started misfiring. I don't even know...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I have a 2001 SL2 Original owner. 5-speed. 390,000 miles.... It started misfiring. I don't even know...

    I have a 2001 SL2 Original owner. 5-speed. 390,000 miles.... It started misfiring. I don't even know exactly when because it was so mild to begin with. It seems to run fine except under load at around 3,200 rpm in 5th gear. Or somewhere above 4,000 rpm in 4th. I can keep the misfire going by feathering the gas petal, or get out of the misfire by giving more gas or backing off. No check engine light. No codes or pending codes stored. I posted on a different forum and was told everything from a plugged fuel filter / bad fuel pump, to oxygen sensor, EGR valve, vacuum leaks (including intake manifold gasket), crankshaft sensor, and stretched timing chain. The EGR valve is a couple months old and was replaced for check engine code. It is actually the second new one as the first failed from the start. I have thoroughly cleaned the throttle body and idle air control module. No change. The crankshaft position sensor didn't change anything. Although this is my daily driver, I can live with the issue and do some testing to narrow things down.



    (Feed generated with FetchRSS)

    More...
    PLEASE DO NOT SEND PM's TO THIS USER. YOUR MESSAGE WILL NOT BE RECEIVED.

    THIS ACCOUNT IS NOT MONITORED, AND IS CONTROLLED BY THE FORUM SOFTWARE

Related Topics

Collapse

There are no results that meet this criteria.

Working...
X