Announcement

Collapse
No announcement yet.

loosing faith

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • loosing faith

    My car hasnt been running very good lately and iv changed everything i could think of.

    New oil
    MMO soak
    new oxygen sensor
    new coil packs
    new egr
    new fuel filter
    new spark plugs
    new sprk plug wires
    new ground cables
    new serp. belt w/o A/C
    fuel ingection service
    new radiator
    new water reseviour

    I baught a scanner and got this
    (code 26) Quad driver output fault - The PCM deteccts an imprper voltage level on the circut that is connected to the Quad Driver Module

    but my SES light only comes on like once a week for a minute.
    all previous codes have been taken care with.

    OK here are my problems
    it does not pick up the way it should.
    When i floor it, it sounds like im flooring it but doesn feel like it at all. seams like i didnt give it any throttle but it does sound like it.
    Smoke at higher RPMS

    things i have noticed
    loud ticking coming from the cylinder head
    coolant disapears after long periods of time.
    runs really really rough in the morning
    trans. has a bad seal
    rotors squeak when they get hot

    what i think
    i think i need a new coolant cap for the missing coolant. Its never been changed and i read on haynes that it could not be keeping the proper PSI

    Im going to run a compression check maybe i need new piston rings, but would it run that bad??

    cylinder head idk why its ticking but i want to replace it soon

    rotors might be wrapped


    anyone want to take a wild guess what it can be?
    I will be running a comp. test today
    Just baught a Big Mac, Throw some Cheese on that bitch...
    <br />
    <br />**i*14: i actually shot a bird for sitting over my car
    <br />
    <br />tool:
    <br />One who lacks the mental capacity to know he is being used
    <br />
    <br />[quote author="Schizzo97SC2"]what have we learned boys and girls? SOHC's are not fast. ever.[/quote]

  • #2
    my guess - bad lifters.
    If you have a cat, that could be clogged also.
    LSJ powered 1998 Chevy S-10 turbo
    visit my Albums - http://sixthsphere.com/album.php?u=7267

    Comment


    • #3
      nope no cat
      Just baught a Big Mac, Throw some Cheese on that bitch...
      <br />
      <br />**i*14: i actually shot a bird for sitting over my car
      <br />
      <br />tool:
      <br />One who lacks the mental capacity to know he is being used
      <br />
      <br />[quote author="Schizzo97SC2"]what have we learned boys and girls? SOHC's are not fast. ever.[/quote]

      Comment


      • #4
        Originally posted by Green Monstah
        my guess - bad lifters.
        [img]{SMILIES_PATH}/thumbsup.gif[/img]

        had the same issue on a vw gti ran horrible...just had bad lifters
        Go turbo or don't go at all!
        <br />-NY
        <br />'94 Turbo SC2
        <br />

        Comment


        • #5
          Originally posted by Green Monstah
          my guess - bad lifters.
          I was thinking the same thing.

          Comment


          • #6
            or, it could also be that one or a couple of the oil runners are clogged up and not allowing sufficient oil to reach the lifters thus causing the ticking noise?

            Comment


            • #7
              im thinking not enough oil because bad rings?
              Just baught a Big Mac, Throw some Cheese on that bitch...
              <br />
              <br />**i*14: i actually shot a bird for sitting over my car
              <br />
              <br />tool:
              <br />One who lacks the mental capacity to know he is being used
              <br />
              <br />[quote author="Schizzo97SC2"]what have we learned boys and girls? SOHC's are not fast. ever.[/quote]

              Comment


              • #8
                Who fucking deleted my post?!

                I said, pour 1qt of trans fluid in your engine, and drive it for a day.

                The next day, drain and fill as normal.

                It's the same as engine flush.

                Comment


                • #9
                  ^im lovin this

                  if it was rings, it shouldnt effect the lifters
                  unless you dont check you oil

                  Comment


                  • #10
                    The ticking has got to be low oil, which is not good. How much of a bitch is it to change your piston rings?
                    2000 Saturn SC2 DD... RIP
                    2009 Ford Escape XLT 3.0L 4x4
                    2009 Yamaha FZ6

                    Comment


                    • #11
                      Originally posted by saturn_06
                      or, it could also be that one or a couple of the oil runners are clogged up and not allowing sufficient oil to reach the lifters thus causing the ticking noise?

                      Comment


                      • #12
                        yeah might have some stuck lifters. but also, have you replaced the ects and the connector to it? i cant remember what exactly to look into with the quad driver though. its one thing i always see pop up but can never remember what exactly to look into.
                        Ian---The Fat Ass

                        1995 SL2-High compression engine FOR SALE
                        2010 Chevy Cobalt SS- tuned with plenty of goodness
                        2002 SC2-New daily
                        2017 Kawasaki Ninja 650 KRT- got a stupid deal
                        2003 Ford Taurus SES- free daily beater

                        Comment


                        • #13
                          quad driver= evap cannister purge solenoid and maybe egr solenoid?

                          Comment


                          • #14
                            i took replaced the egr

                            and whats the evap canister purge?
                            Just baught a Big Mac, Throw some Cheese on that bitch...
                            <br />
                            <br />**i*14: i actually shot a bird for sitting over my car
                            <br />
                            <br />tool:
                            <br />One who lacks the mental capacity to know he is being used
                            <br />
                            <br />[quote author="Schizzo97SC2"]what have we learned boys and girls? SOHC's are not fast. ever.[/quote]

                            Comment


                            • #15
                              little solenoid on the back of the engine block
                              and the code is for the egr solenoid not the egr itself

                              Comment

                              Related Topics

                              Collapse

                              There are no results that meet this criteria.

                              Working...
                              X