Announcement

Collapse
No announcement yet.

Ok this is REALLY pissing me off...whats the deal.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ok this is REALLY pissing me off...whats the deal.

    Everytime I get my bottle filled I get maybe 6-7 pulls (not even 0-100 runs) and then my shots start feeling a little weaker. I call it a night, try again another day and I get absolutely nothing...I purge and I get nothing but air!

    Half my fuckin bottle is filled with air every damn time! What the hell is going on? I've taken it to two different places with the same results...

    This is frustrating as hell because this is like the 3rd time I've went through a bottle in one day.

    Whats the issue here?
    [img width=461 height=118]http://i44.tinypic.com/2likitg.png[/img]

  • #2
    Are you sure you have the bottle in the correct position?
    Got a new baby <img src="{SMILIES_PATH}/smile.gif" alt="" title="Smile" /> - 2006 Ion Redline Stage 2<br /><br />Old baby :<br />--My ride : http&#58;//www&#46;cardomain&#46;com/ride/405827

    Comment


    • #3
      Re: Ok this is REALLY pissing me off...whats the deal.

      Originally posted by IonNinja
      Everytime I get my bottle filled I get maybe 6-7 pulls (not even 0-100 runs) and then my shots start feeling a little weaker. I call it a night, try again another day and I get absolutely nothing...I purge and I get nothing but air!

      Half my fuckin bottle is filled with air every damn time! What the hell is going on? I've taken it to two different places with the same results...

      This is frustrating as hell because this is like the 3rd time I've went through a bottle in one day.

      Whats the issue here?
      what size shot are you running, what size bottle? do you have a bottle warmer or a gauge?
      97 sc1-- DOHC swap, P&amp;P head, race cams, AEM CAI, geo TB, eclipse 4-1 header, lsd, act clutch, fidanza FW<br /><br />na<br />14.9 @91mph<br />50 shot <br />[email protected]<br /><br />forged motor coming soon..<br /><br />vids<br />http://videos.streetfire.net/profile/bo ... dewayz.htm

      Comment


      • #4
        75 shot, 10lbs bottle, have a bottle warmer & gauge...

        hmmm, could this be the problem?




        It is mounted slightly to the side because the fittings are too big for it to fit properly lined up straight.

        you know what though, now that I think about it...I've taken the bottle out on a couple occassions and opened it up before and nothing but air came out.
        [img width=461 height=118]http://i44.tinypic.com/2likitg.png[/img]

        Comment


        • #5
          is that a remote digital gauge line? I don't think that little bit of angle is your issue, what is the PSI when you have the heater on?
          sigpic

          Comment


          • #6
            its for my bottle heater, its pressure monitored...when my heater is on its always within 900-1000psi when I spray.

            I thought warmer nitrous would last longer :evil:
            [img width=461 height=118]http://i44.tinypic.com/2likitg.png[/img]

            Comment


            • #7
              my guess is you have a leak somewhere. i would start at the pressure switch and gauge seen in picture. my n2o gauge actually had a leak when i first got it. just needed to be tighten.
              2007 chevy classic 2500hd 4x4 duramax
              1996 383 lt1 auto trans am
              1995 sl1. single cam of fury
              1995 jeep wrangler lifted 4x4 4.0
              1995 ford explorer 4x4

              Comment


              • #8
                don't you need the bottle mounted in a 45' position?
                CSW Tuning or Facebook!
                - Stork

                Comment


                • #9
                  Originally posted by 325iwhat
                  don't you need the bottle mounted in a 45' position?
                  i think its closer to thirty, but it looks like he has the brackets set right.


                  like sl2racer said, check for leaks, you should be able to hear it if it's leaking. if you can't hear it, run your hands down the whole length of the line. if it's leaking the junction or part of the line should be frosty
                  97 sc1-- DOHC swap, P&amp;P head, race cams, AEM CAI, geo TB, eclipse 4-1 header, lsd, act clutch, fidanza FW<br /><br />na<br />14.9 @91mph<br />50 shot <br />[email protected]<br /><br />forged motor coming soon..<br /><br />vids<br />http://videos.streetfire.net/profile/bo ... dewayz.htm

                  Comment


                  • #10
                    weigh the bottle next time you have it filled, it should be 14.5 lbs empty, and 24.5lb full...if they are not using a pump and just hooking it up to another bottle and haveing it fill into yours, then you need to put the bottle on ice before you go and get it filled. You can also try to use a vacuum pump and hook it to your bottle, close the valve, and then chill it. You might get 11 lbs or so that way.
                    -6S Resident Mechanical Forensics member #001.
                    1995 SC2 Turbo 3.6L DOHC, 6sp manual, Ford 8.8 rearend running on MS3x.
                    1998 F-250 5.4L triton...stock.

                    Comment


                    • #11
                      Do you close the valve after each use? I mean, if you leave the car overnight somewhere do you leave the bottle open?
                      - Jeff Silva
                      2001 Chevrolet Tahoe Z71 5.3L, Blackbear tune, cranked keys, e-fans, Android head unit
                      1997 Dodge Caravan SE 3.3L V6 family hauler
                      Vacancy here, need project car

                      Comment


                      • #12
                        I haven't weighed the bottle yet...I will start doing that though, thanks for the #'s.

                        I doubt I have a leak, you would definitely hear it with my bottle fully opened and I don't. Plus the reason my gauge is so retarded and not visible unless I get out and look is because I've got it tight at all points to where there are no leaks. Yeah when I installed my NOS gauge it was loose as well...and leaked.

                        I do purge everytime I am done using nitrous until the lines are completely clear.

                        Also my bottle is always frozen before getting filled. The last time it was frozen for 2 1/2 hours before filled (vs 1 hour chill time previously) and no difference.

                        Today I froze my bottle for 5 hours before I went to get it filled. I took it out tonight and actually got about 5 or so races in so we'll see how long it lasts.

                        Maybe I'm just expecting more than I should?
                        [img width=461 height=118]http://i44.tinypic.com/2likitg.png[/img]

                        Comment


                        • #13
                          Maybe the shop is fucking you and giving you half and half.....
                          2015 Ford Mustang - DD
                          2013 Kia Sorento SX V6
                          1978 Buick Century Custom - 42k Original Miles

                          Comment


                          • #14
                            Originally posted by Tek
                            Maybe the shop is fucking you and giving you half and half.....
                            Thats what my guess is.

                            Comment


                            • #15
                              weigh it. with a 75 shot, you should get a good 15 pulls or so out of it (depending on how much you purge, waste, etc).

                              i would go with the shop is fucking you, so ask them to weigh it AFTER they have filled it. make sure you empty the bottle completely before you take it to them so they cant use some bullshit excuse of it having some in it already.
                              Doug<br />1997 Black Gold SC2<br />2001 Silver SC2<br />Rollin' on 20's<br />

                              Comment

                              Related Topics

                              Collapse

                              There are no results that meet this criteria.

                              Working...
                              X